Buffering for put?

Jul 28, 2010 at 9:10 PM

Sorry if I missed the topic in the docs but I am encountering an error using the put command.

C:\S3>s3 put %mybucket%/logs/test/ s3_help.txt /key:%key% /secret:%secret%

s3.exe version 1.7 - check for updates at http://s3.codeplex.com

 

logs/test/s3_help.txt

This request requires buffering data to succeed.

 

What the heck is that? The file is 2kb...

 

Jul 29, 2010 at 7:14 PM

NM I got it to work.

Coordinator
Jul 30, 2010 at 1:28 AM

Looks like a problem connecting through your web proxy.

Jul 30, 2010 at 8:31 PM

Actually the problem was between the keyboard & chair, but it's working now.

:)

Aug 3, 2012 at 1:55 PM

How did you solve this? I have the same problem, but nothing works for me!

Nov 30, 2013 at 11:17 AM
I have the same question as nivram85. I get the same error on my work PC (behind firewall and proxy), but not from my home one.

If you are still around, dsnye, please do let us know how you solved it!
Dec 2, 2013 at 3:23 PM
Edited Dec 2, 2013 at 3:23 PM
I saw this error on NOT US buckets.
So, I created US bucket (select region US Standard when creating) and all works fine!
Jan 23, 2014 at 12:36 AM
Having the same issue as well, I really wish one of you posted your solution. Switching to a US bucket isn't really a practical solution...
Jan 23, 2014 at 6:53 AM
Ok for me this error mysteriously disappeared.

Steps I took to try and fix it which you could try
  • Make sure your S3 bucket complies to naming conventions (wasn't an issue for me but probably a good place to start)
  • Try recreating the bucket
  • If you're using IAM, re-apply your policy to S3 (just edit it an re-apply)
  • Reboot your computer/server
May 12, 2015 at 1:03 PM
I had this error too. It is still a problem.

I tested Ireland and Frankfurt - they don't work

Solution: make sure the bucket is in the USA Standard Region
May 13, 2015 at 5:40 PM
If you add the backup or sync command, do you the same error?
May 13, 2015 at 5:45 PM
Edited May 13, 2015 at 5:45 PM
Sorry, not tested that as don't really need it in my use case. Are you saying that if we add these commands it should work?
Coordinator
May 13, 2015 at 5:51 PM
Sadly s3.exe development has been at a standstill for five years, so some problem I don't know about might have crept in.

However, have you checked the "Challenges with Non–DNS-Compliant Bucket Names" section in the document seanious links to above? If it's working in the US but not elsewhere then that seems a very likely explanation.
May 13, 2015 at 5:53 PM
Edited May 13, 2015 at 5:54 PM
Actually I did scan it and my buckets are all in the form n.n.n.n where n is a variable number of letters and numbers only.
Oct 19, 2015 at 7:08 PM
jcrick wrote:
Sorry, not tested that as don't really need it in my use case. Are you saying that if we add these commands it should work?
The same thing happens to me, and I had to use the sync option. The backup option does not use it because you do not actually use.
Feb 6 at 3:36 PM
Edited Feb 6 at 4:11 PM
It looks like on newer s3 regions, Amazon has changed their requirements. I tested the s3 command line tool from AWS versus s3.exe in us-east-2 (Ohio) and the error from Amazon was "You are attempting to operate on a bucket in a region that requires Signature Version 4. You can fix this issue by explicitly providing the correct region location using the --region argument". So I specified region and it took it. Since s3.exe does not support passing in regions, you will have to use an older s3 region, like East1, West1 or West2, all which worked fine for me. I will be switching to amazons CLI instead so I can use east-2.