List gives Forbidden 403 error

May 24, 2010 at 7:23 PM
Just came across this useful command line and tried it out immediately. When I list all my buckets, everything works just fine: s3 list /key:my_key /secret:my_secret /nogui s3.exe version 1.6 - check for updates at http://s3.codeplex.com bucket2 bucket2 bucket3 bucket4 bucket5 bucket6 6 files listed When I try the to list the content of one of the buckets I receive "The remote server returned an error: (403) Forbidden." Commando used is: s3 list bucket5 /key:my_key /secret:my_secret /nogui I had initially bucket names with underscores in them, but even using just letters in the name gives the error. Any idea what this can be? Running Vista SP2.
May 24, 2010 at 7:42 PM
I did some further testing and the error arrives when using a European bucket. With a US Standard bucket it works just fine.
Coordinator
May 25, 2010 at 5:59 AM

Hi there,

I haven't much used European buckets so there might be a bug, but it worked when I just tried it.  Have you checked the permissions on your bucket to ensure you're allowed to list it?